Fixed "Collective" cards causing game error


New member
When casting Collective Brutality for 2 Modes, an error will pop up causing the game to shut down after sending an error report. This has happened 2 different times in 2 different matches.


New member
I can easily recreate it in open play with just myself as a player, it happens every time. But here is a game ID: 819090768


New member
When selecting collective brutality to escalate once, the game will send an error message and bug out. You can collective brutality without escalate mode, and two modes, but not ONE modes. Very strange. I tried casting it three times but bugged every single time, then tried escalate 2 modes and it worked, very strange.


New member
In a modern league match, I went to cast collective brutality with escalate. I click "escalate with two modes".

The moment I do this, the game gives me a crash report. Because I was interested in getting back into my game ASAP, I quickly hit 'send report' and the game window closed.

Upon re-loading, I try again... this time it repeats with the error, but I return to find my match has also been conceded despite all of this happening in a very short time.

I believe escalating, at least this card, is bugged.


New member
I tried to escalate collective brutality in a league yesterday and the game crushed. today during league #7046 match #254105739 happened the same at least twice. i lost 2 matches due to that.
1. fix the card
2. give me some tix/chest as a refund
thank you in advance

New member

When casting with escalate, the game crashes.


New member
Collective Brutality is bugged. If you want to escalate 2 mods game crashed and show you some report table.

When I try to escalate collective brutality to use two modes it crashes mtgo. How do I file for reimbursement for my league?
My opponent (2Clo) was playing collective brutality and they said their computer crashed when trying to escalate it, so based on this the card is bugged. I am unsure of further details.